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1 INTRODUCTION 

DMX (Digital Multiplex) is a handling protocol used for event technology, so it is robust, fail-safe and 
built up simply. The standard as of today exists since 1990 and due to its wide spread distribution it 
offers a lot of functionalities by low asset costs. 
 
For use in house building DMX is very attractive for RGB LED control. In order to integrate this solution 
within existing systems and environments without problems a proper gateway is needed. This gateway 
allows transmitting control commands from one “world” to another. 
 
 

2 THE GATEWAY 

The DUO DMX Gateway is laid out for ceiling installation. Due to its compact measures it can be used 
for complicated mounting lays too. The device provides 2 DMX output channels and so it is able to 
handle two different circuits at the same time. 
Specifications: 
 
Mounting:    Ceiling installation / DIN Rail Bar adapter: 

DIN Rail Bar EN 50022 – 35x7,5 
Measures (W x H x D) in mm:   without grounding clip: 50x26x116 

With grounding clip: 50x26x146 
Power supply:    10-30 V DC 
Power consumption:   <= 1,2VA 
Connection:    Power over Ethernet (PoE) or Power supply via  

connection clamp 
 
Interface (depending of model type): 
KNX     via connection clamp (Twisted Pair) 
Ethernet    via RJ45-jack 
EnOcean    via external SMA antenna 
2xDMX 512    Connection clamp nominal wire size: 1,5mm² 
Pushbutton input   Connection clamp nominal wire size: 1,5mm² 
 
Power supply can be realized separately via the 12- 30 V DC connection or will be provided by PoE 
(Power over Ethernet). 
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3 MOUNTING 

The device can be used for installation in ceilings or alternatively for DIN Rail mounting. In case of 
ceiling mounting the device has grounding clips on each side. For DIN Rail mounting an additional 
adapter has to be used. The grounding clips can be broken off easily if wanted. 
 

 
Figure 1: DUO DMX Gateway with grounding clips 

 
DIN Rail Bar adapter 
The adapter is fixed on the chassis with 2 screws (part of delivery). Please note that the adapter only 
may be screwed in the two folded holes.  
 

 
Figure 2: DIN Rail Bar Adapter 

 
Note: Please attach the DIN rail Adapter only on the two marked holes. Using the wrong holes the 
screw ends might touch the bottom of the circuit board! 
 
Please be careful if you need to troubleshoot a device mounted on the DIN rail. Pull with too much 
force on the gateway, the screws can be pulled out from the chassis. 
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3.1 CONNECTION PLAN 

In the following image you will find an overview over the connection the DUO DMX Gateway offers in all 
available variants. 
 
 

 
Figure 3: DUO DMX Gateway - connection overview 

 
Device model: Extension 
As an extension the unit is controlled via the "BMX" protocol of eibPort. 
Communication takes place over the network. Therefore the device has to be connected to the local 
network. 
 
Device model: KNXnet / IP 
As KNXnet / IP version the device's control commands are received via the "KNXnet / IP" protocol. 
Therefore, the device must be connected to the network, too. 
 
Device model: KNX / TP 
As KNX Twisted Pair version, the device is directly connected to the twisted pair wiring of the KNX bus. 
For this purpose the device has two terminals on one of the connectors. 
 
Device model: EnOcean 
The EnOcean device can manage by the control signals of EnOcean radio. The device only requires a 
power supply. Moreover, the external antenna of the device can be connected. The link to the EnOcean 
profiles is done with the software DMX Configurator. 
 
Connection with the DMX bus 
The device has two independently from each other acting DMX outputs. The connection is realized via a 
6 pin Screw terminal, the polarity is marked on the case. Of course it can also be used with only one 
output connector. 
 
 
  



 Put it into Operation DUO DMX Gateway 

 

8 b.a.b-technologie gmbh DUO DMX Gateway  

 

4 PUT IT INTO OPERATION 

When ceiling mounted, the gateway can be installed near the DMX system. For operation you need the 
following components: 
 

 Power supply (or PoE) 
 connection to the network (not mandatory, but would be an advantage) 
 connection to the DMX bus 
 connection to one of the controlling medias (network, KNX or EnOcean) 
 the software "DMX Configurator" 

 
The configuration for the device is done using the software "DMX Configurator" over the network or a 
SD-card. It does not matter which device variant shall be configured. Alternative: To take the device into 
operation by using the SD card, you need a standard SD card and a card reader for your PC. 
 
 

4.1 DMX-CONFIGURATOR INSTALLATION 

Please first install the software “DMX-Configurator”. The setup file for installing the software "DMX 
Configurator" can be found on the CD or can be downloaded at www.bab-tec.de. The Software is MS-
Windows® based. 
 
Installation Instructions: 
Please double-click the file "setup.exe". The Setup dialog opens: 
 

 
Figure 4: DMX-Configurator - Setup Dialogue 

 
By clicking on "Next" you can move through the menu. Accept the license agreement and select an 
installation location on your hard disk. Select "Finish" at the end and the installation wizard has installed 
the program on your PC. 
 
After installation you find the program under "Start"> "Programs"> "DMX Configurator". 
 
Update the DMX Configurator Software 
Do you want to install a newer version of the DMX Configurator, it is important to uninstall the old 
version first properly. To do this go to "Start"> "Control Panel"> "Programs and Features" (in Windows 
XP "software") and then remove the "DMX Configurator". Now select the new setup file and proceed as 
described above.  

http://www.bab-tec.de/
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4.2 DEFAULT SETTINGS 

The DUO DMX Gateway is delivered with the following factory settings: 
 

 IP-address: 192.168.1.223/24 
 Device name: MAC Adresse des Gerätes 
 Physical address KNX: 15.15.255 
 Mulitcast address KNXnet/IP (“Routing”): 224.0.23.12 (cannot be changed) 
 eibPort System ID: 0 (cannot be changed, important only for type 12000) 

 

4.3 INITIAL COMMISSIONING 

Connect the standard 10-30V power supply (DC) to the connection clamps or connect the device to 
PoE enabled network cable. The power LED is lighting green if the device is in operation. 
 

 Start the DMX-Configurator and browse to the menu “Extensions” – “DUO DMX Gateway”. 
 

 
Figure 5: DMX-Configurator – extensions 

 
 You will be asked to choose the device type you are using. “KNX/BMX” is for the device types 

“Extension” (Art.-No. 12000), “KNXnet/IP” (Art.-No. 12010), “KNX/TP” (Art.-No. 12020). 
“EnOcean” stands for the device type “EnOcean” (Art.-No. 12030). 

 

 
Figure 6: DMX-Configurator - device Selection 

 
 Now the window “KNX” or “EnOcean” opens. 
 Now please switch to the tab “Lan/KNX” on the right side and push the button “Search” below 

the array “DMX-Gateways”. Following that, you will get shown all DUO DMX Gateways available 
in your network not depending on their network settings. For device type “EnOcean” the 
corresponding tab is called “Lan/EnOcean”.  

  

 
Figure 7: DMX-Configurator - Window Lan/KNX 
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Note: If the device is not shown the array after pushing the “Search” button, ther is probably a 
problem with your network connection (e.g. firewall / router settings). Please check this. In case 
of doubt please contact the BAB Technologie Support.  
 
For a first step you should configure the device with the desired network settings, in order to use it 
normally in your local network. Please proceed as follows: 
 

 Browse the tab “Lan/KNX” resp. “Lan/EnOcean” and change the IP-address corresponding your 
desires. 

 

 
Figure 8: DMX-Configurator - IP-Adress Settings 

 
 Allocate a device name 
 Press the “Search” button and check the current settings of the DUO DMX Gateway. With 

default settings the device has the IP-address 192.168.1.223, its name is its MAC address and it 
is giving out his firmware version number.  

 

 
Figure 9: DMX-Configurator – device search 

 
 Open the network settings of your PC and assign it an IP-address in the subnet 192.168.1.x, 

e.g. the address 192.168.1.10. If the device is not shown with the default IP-address in the 
array “DMX-Gateways”, the address of your PC must be assigned different accordingly.  

 

 
Figure 10: Windows - Network Settings 
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 Now switch back to the window of DMX-Configurator and mark the desired device in list “DMX-

Gateways”. By clicking “Upload” the current settings out of the DMX-Configurator will be 
transmitted to the DUO DMX Gateway. A successfull transmitting is been confirmed with the 
message “Upload done”. If not you will get an error message. In this case please check the 
network settings of your PC and the DUO DMX Gateway once again.  

 

 
Figure 11: DMX-Configurator - transfer configuration 

 
 After that please leave the window “KNX” or “EnOcean” by clicking the “OK” button and save 

the current setting with the help of the menu “File” – “Save as” as project file “*.dx1”. Please 
use this project file later for the further project settings.  

 

 
Figure 12: DMX-Configurator – save project 

 
Advice: If you want to use a new project file, please consider the IP-address settings. Every new 
project contain the default IP-address settings again. With uploading data of a new project once 
again the device would set back to the default IP-address settings.  
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4.4 IMPORTANT VERSION INFORMATION 

Find Software version  
The version number of the DMX-Configurator can be read in the title bar of the window. 
 

 
Figure 13: DMX-Configurator Version 

 
New software and firmware 
Since the DMX Configurator Version 1.6.0.0 the software only will work with devices that will have at 
least firmware 2.0.0.1. To check which firmware you have in use in your device, please use the "Search" 
function in the tab "Lan / KNX" in menu "Extension". Compare also the chapter "Activating the DMX 
Preview". The firmware version is displayed along with the IP address and device name. 
 

 
Figure 14: Displaying firmware version 

 
If your device does not have the required firmware version a firmware update is required (see "Firmware 
Update"). If a device received once the firmware 2.0.0.1 or later, it may have to copy the configuration 
data only from the DMX Configurator 1.6.0.0 or later. If you have an older version of the DMX 
Configurator, please download the actual one from our homepage. 
 
Older project data 
Projects from older versions of DMX-Configurator can be opened without problems in the latest 
software version. Once a device is already loaded with a configuration before a firmware update is 
done, it  has (after the firmware update is done)  to be reloaded with the software (1.6.0.0 or later) into 
the device. 
 
 

4.5 BEHAVIOUR IN CASE OF POWER FAILURE 

Behavior in case of power failure 
The behavior of DMX devices in a power failure at the DUO DMX Gateway depends on the devices its 
one. According to DMX specification a subscriber moves to a safe operating condition (eg, lamp off). By 
return of the power supply, all DMX channels set to the value "0". 
 
Behaviour on bus voltage failure (only KNX / TP device) 
In the event that the bus voltage fails but the power supply of the device remains upright, only the 
control of the DUO DMX gateway is interrupted. The DMX signal is still sent, so the current "picture" of 
the DMX outputs remains. Even after the return of the bus voltage nothing varies in the DMX range 
(unless new KNX telegrams are send). 
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5 PROGRAMMING 

The programming of the DUO DMX Gateway is done over the DMX-Configurator. There the scenes are 
set up, the Group Addresses resp. EnOcean Profiles are linked to the dim outputs or the scenes. The 
configuration is transferred over the network or over an SD-card into the device.  
 
 
 

5.1 ENABLING THE (DMX-) PREVIEW 

In conjunction with the DUO DMX Gateway the "DMX Configurator" software provides a so called "DMX 
Preview". In the preview all DMX channel controls changes are sent to the gateway over the network, so 
you are able to see directly the changes of light. In this way, the sequences and scenes can be tested 
directly and modified if necessary without transmitting the data beforehand. This makes the 
configuration much more easier. Enable the Preview in order to display you configuration entries 
directly at the DMX end devices by adapting the following configuration instructions.  
 
The preview can be done in two ways 
 

1. Broadcast Preview: All DUO DMX devices in the network are addressed using the preview no 
matter what network settings you have and whether they just allow the PC from the DMX-
Configurator to be started. The preview will be sent via Broadcast signals into the network. 
 

2. Unicast Preview: Only a selected DUO DMX Gateway receives the preview signals. It is 
important to note, that the desired gateway and the PC are within the same network area. The 
signals are sent via Unicast to a specific IP address. 
 

Which of the two DMX outputs are used for the Preview signals can be choose. To activate the preview, 
go to the menu "Extensions"> "DUO-DMX Gateway". 
 
Activation of the broadcast Preview 
To activate the broadcast preview just one of the two (or both) checkboxes "DMX Out 1" or "DMX Out 
2” has to be selected. Choose your selection and confirm with “OK”. From now on, the preview will be 
sent via broadcast signals into the network and interpreted by all available gateways. 
 
 

 
Figure 15: Broadcast Preview 

 
Note: The preview is no setting that is transmitted to the gateway or will be stored in the project 
data of the DMX-Configurator. This setting is only to be activated on the client. 
 
Activation of unicast Preview 
To preview specifically addressed to a particular device, it is necessary that the appropriate device 
appears in the list "DMX Gateway." To achieve this, click the button "Search". Thus, all are located in 
the network devices with IP address and device name (default setting the MAC address). If one of the 
devices in the list marked in blue, is the only active Preview for this device. 
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Figure 16: Unicast Preview 

 
Note: Please note that the PC and the DUO DMX Gateway must reside in this case in the same 
area network (subnet)! 
 
To set the DUO DMX gateway to the desired IP address range, please have a look at the section 
"Extensions". 
 
Firewall settings 
If a firewall is installed on the client computer it must be unlocked for the DMX-Configurator for ports 
4042, 4044 and 4045. 
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5.2 DMX CONFIGURATOR 

The DMX control software “DMX Configurator” is used to create light images (Step) and light scenes 
(Scene). The configuration data following out of that will be transferred over the network or by SD-card 
to the device. Apart from that, a preview function shows changing’s on the DMX-controllers of the DMX-
Configurator directly on the DMX end devices. The software is supplied with the CD and is suitable for 
all current Windows systems. 
 

5.2.1 USER INTERFACE 

The user interface is clearly structured into five broad areas. 
 

1. Administration of the scenes 
2. Scene settings 
3. Administration of steps  
4. DMX channel settings  
5. Menu bar settings 

 

 
Figure 17: DMX Configurator – User interface 

 
 
 
Using the menu bar to configure various features of the software and hardware can be reached. These 
are described separately below. 

 

  

1 4 

5 2 3 
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5.2.2 CHANGE MENU LANGUAGE 

In order to change the menu language of the DMX-Configurator, open the menu under the "?" 
(Question mark). The DMX-Configurator must be restarted for it! 
 
 

5.2.3 GENERAL DESIGN OF THE DATA STRUCTURE 

The input of the sequence is done in two steps. First a scene is created, forming a so-called envelope for 
each step (Steps) of the light flow. 
 

 
 
A scene can contain one or more steps, where at a static light image is generated by only one step or a 
dynamic light image with multiple steps. 
 
 

5.2.4 GENERATING SCENES 

Before the entry of individual steps can be made a scene must be selected or created. 
 

Creating a new scene takes place with the button  . 
 
A new entry scene is inserted into the scene list. This name can be edited freely.  
 

The Button  copies all selected scenes including all their steps. 
 

 deletes the selected scenes including all their steps. 
 

The arrow box  serves for displacing the scenes within the scene’s list. 
 
Important Note: 
At the start of each scene the DMX-Configurator is assumed that the 
corresponding DMX channel holds the value "0". If not so, it may happen that 
a new scene added up its DMX values to existing values (of the old scene). The 
lamp will display incorrect values. 
 
That behavior does not occur if each scene is first started with a step, with the 
value "1" and a subsequent step with the value "0". Between the two steps is 
not a "fade" and a minimum "wait time" of 50 ms. In this way, each DMX channel is set to the 
value of "0" before starting the actual scene. Maybe it is reasonable to create a special scene, 
which only serves to set "0" to the desired DMX channels. 
  

PROJEKT
SZENE 1

SCENE 2

STEP 1
STEP 2
STEP 3

STEP 1

Figure 18: Scene’s list 
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5.2.5 CREATING OF STEPS 

By creating and editing steps, the individual light image is created and when linked together, a dynamic 
light image will follow. Static light images are to create with only one step. 
 
 
 
 

 
Figure 19: Steps erstellen 

 
 
 
 
For the setting of different DMX values 12-channel slide controls are available. These are labeled with 
the channel number. To reach all 512 channels, you must select the underlying horizontal scrollbar. 
The additional existing Channel direct access buttons are modified under "Application settings". There 
the assigned DMX channel numbers are set, which are then accessed at once by pressing these buttons. 
 
Per step, different DMX values for each channel can be set. By stringing together several steps with 
various DMX values a dynamic light image can be created. The "step list" includes all steps in 
chronological order. The transition between two steps determines the cross-fade (Fade time) and hold 
time (Wait time), which can be set separately for each step. The option "Change all steps" is for to 
change the "Fade Time" and "Wait Time" to all landscaped steps in the Step list. 
 
Get DMX IN 
Not in function for the DMX Gateway. 
 
Rotate channels left / right  
Causes the set all DMX values are shifted by one channel to the right (+1) or left (-1). This allows the 
easy creation of "chaser" scenes. 
 
  

Step-Liste 

Channel Control 

Channel – direct access button Shift to left Shift to right 

Faid and Hold 

Reapeat Scenes 

DMX-Value 
Input 

DMX-Group Control 

DMX-Master Control 
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5.2.6  COLOR PICKER 

The color picker makes entering RGB color values easy. In this case be 3 
consecutive DMX channels, the R / G / B values of a selected color is assigned. To 
achieve the color picker, click on the first RGB (of 3) DMX channels with the right 
mouse. 
 

This opens a menu with the  then the left mouse button must be 
clicked. 
 
The dialogue of the Color Picker is available in 2 different views. Left the standard 
representation (normal style) and the on the right color distribution as color wheel (round style) is 
shown, 
 
Go for color selection as follows: 

 Select the color from the color representation 
 Select the color brightness 
 Click on OK and the settings for R / G / B can be taken 

 
 
 

                      
Figure 21: Color Picker – different views 

 
 
 
Note: By clicking the right mouse button on the controller for color brightness make this center 
to 50%. 
  

Figure 20: Color 
Picker selection 

brightness 

Color shape 
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5.2.7 DMX-GROUPS 

DMX groups are suitable for simultaneous editing of multiple channels. There are 16 groups available 
where you can combine any channels. 
 
To create or edit the group, select in the menu "Settings"> "Application settings" and then choose the 
Tab "Groups”. 
 

 
Figure 22: define DMX groups 

 
In the box next to the group name the DMX channels must be entered, which form the group. Here, the 
separation of DMX channels is made with a semicolon. One DMX-channel can belong to different 
groups. 
 
After you define the groups you will see them in the group selection. By selecting a group, the selected 
channels are marked in the box and activated. They are tied together and all channels are set to the 
same value as soon as one of the fader is changed. 
If you need additional channels that are not defined as a group, you can add them by manually 
selecting the check box temporarily. 
 

 
 
 
 
 
 
  

Displaying the connected channels 
group selection 
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5.2.8 DMX-MASTER GROUP 

A special group is the master group. The listed DMX channels can be scaled to the output on the 
connected interface according to the master value. 
 
Example 1:  DMX value = 100%;  Master = 50%  50% results in the output channel 
 
Example 2:  DMX value = 50%;  Master = 50%  25% results in the output channel 

 

0 0 
 
 
 

5.2.9 COUPLING OF SCENES  

What action is executed after the last step in a scene is set by the selection box under the step list. 
 

• Repeat after last step: The scene is running in an endless loop. 
• Stop after last step: The scene will stop the execution after the last step. The light image 

of the last step remains unchanged. 
• Execute: The selected scene is performed after the last step. 

 
 

5.2.10 SAVE AND LOAD PROJECTS 

Under the File menu, you can store your steps and created scenes as a project and 
open it again. The created files are in the specific format *.dx1. 
 
 
 
  

DMX-Master 

activate BlackOut  

Figure 23: DMX 
Master Control 

Figure 24: Load 
and save projects  
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5.2.11 EXPORT AND IMPORT SCENES 

In addition, you can save individual scenes separately. This is useful if you need the same 
scene in another project. To save individual scenes using the menu Scene -> Export. The 
saved file has the extension "* scn.".  With the menu Scene -> Import an exported scene in 
your project is added. 
 
 

5.2.12 EXPORT AND IMPORT OF STEPS 

The separate storage of Steps is analogous to these of the scenes. To save individual steps 
using the menu Step > Export. The saved file has the extension "*. stp". The menu item 
Step> Import you can add a step to the end of the step list. 
 
 
 
 

5.2.13 RGB EDITOR 

The RGB Editor is specifically designed for the production of light images with 
LED stripes or LED panels. Enable the DMX-editor in the menu under Settings> 
RGB Editor. The sliders are replaced by colored rectangles. These represent the 
individual RGB channels. 
 
 
 
 
5.2.13.1 CONFIGURE RGB EDITOR  

You can configure the display and the assignment of 
the RGB settings to the DMX channels. To do this, 
select the menu item Settings> Application settings 
and then go to the Tab RGB Editor. 
 
This opens a dialog where you will find the following 
settings: 

 Pixel H: Indicates how many RGB fields should 
be arranged horizontally. 

 Pixel V: Indicates how many RGB fields should 
be arranged vertically. 

 First Pixel offset: Specifies how many DMX 
channels are before the first pixel 

 Channels/Pixel: Specifies how many DMX 
channels can be assigned to a pixel. Follow all 
RGB channels directly on one another, is here to provide third More control channels or a 
channel W are used, must be stated here also that much more. 

 Example: The DMX4all LED dimmer is indicated here since five channels for a total of 5 RGBW 
and STROBE are used. 

 Channel R: Specifies which (first) channel is assigned to used RED 
 Channel G: Indicates which channel is assigned to the used GREEN 
 Channel B: Indicates which channels is assigned to used BLUE 

 
ATTENTION:  
RGB fields to a maximum of 512 channels can be predefined. 
  

Figure 26: Export 
and Import of 

Steps 

Figure 27: start RGB 
Editor 

Figure 28: RGB Editor Configuration 

Figure 25: Scene 
Export and Import 
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5.2.13.2 USE OF RGB EDITOR  

Also be using the RGB Editors has generating scenes and steps as before. Have you created a step, the 
current information will be displayed on the RGB color fields. 
 

 
Figure 29: Color Picker 

 
You can edit the individual fields by clicking the right mouse button on the RGB box. It now opens a 
menu from which you select “Color Picker”. This will open the Color Picker window as already known. 
 
In order to copy colors from one field to another, simply click the right mouse button on the RGB box 
and select “copy”. Now you can click on “paste” or -by using the left mouse button in an RGB color box 
– “copy” it direct in place. 
 
NOTE: After you select a new color with the Color Picker, this color is automatically used by 
“copy”. This is indicated by the colored arrows at the cursor. 
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5.2.14  CHANNEL SOFTPATCH 

To edit the soft patch settings, select the menu item “Settings2> 2channel soft patch”. 
 
The column “output channel“ allows a subsequent matching of existing scenes to a other existing 
installation. Thus, the scenes remain unchanged and only the assignment of the individual channels 
must be new. No double seizure 
 
In order to terminate the input with no changes, press Cancel. Press “OK”, changes into the current 
project are accepted. Reset restores the default settings. 
 
NOTE: In one project (dx1-File) only one separate channel setting is possible! 
 
 

 
Figure 30: Channel Soft Patch 
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5.2.15 DEVICE MANAGER 

Call the Device Manager under menu Settings→Device manager. 
 

 
Figure 31: Device Manager 

 
In the left part the DMX addresses are listed in a table. For each DMX address a name can be given 
which is clear to the user function. The entry of the name occurs in the input box on the right side of 
the selected DMX address (in the picture above for address 11). 
 
Standard color channel 
Furthermore, an additional info for each channel can be deposit. In standard this is an info over the 
color that is controlled by this DMX address. For color selection, click the right mouse button on the 
color box to the right and select the color from the list that opens. With “User Defined”, you get to the 
color picker where you can select an individual color. 
 
RGB Device 
The “RGB device” offers you the RGB display of mixed color. This is the display of the 
individual DMX channels shown in the main window as in the right example. 
 
 
  

Figure 32: Display 
of mixed colors 
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5.2.16 APPLICATION SETTINGS 

Under the menu “Settings”> “Application settings” 
changes for the main program are possible. 
 
The settings are divided into several groups. 
 
“Load Program” specifies file on startup, which is loaded 
when starting the software. 

 “None”: There is no project loaded 
 “Load specified file”: it will load the specified 

project. With  the project file is selected. 
 “Load, last opened file”: The last opened 

project is loaded 
 
 
 

5.2.17 STORAGE LEVEL INDICATOR 

Since DMX Configurator Version 1.6.0.0, there is a storage level indicator. The DUO DMX Gateway has a 
total space of 64 Kbytes. The level indicator shows you how much of this memory is used in your 
current configuration. Transfer more information to a device, there will be malfunction. 
 

 
Figure 34: storage level indicator 

  

Figure 33: Application Settings - File 
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5.3 MENU „EXTENSIONS“ 

The specific settings for the DUO DMX Gateway are made in the menu "Extensions". Here the linking 
with the group addresses or EnOcean profiles, IP address assignment, and the transmission of 
configuration data is made. In addition, devices can be detected on the network and the DMX preview 
is enabled. 
 

5.3.1 SELECTION OF TECHNOLOGY (VARIANT) 

Before the configuration of the DUO DMX Gateway starts, there must be the selection of variants, 
whether it is a "KNX / BMX" or an "EnOcean" model. Overview of unit types / technologies: 
 
KNX/BMX 

 12000 Extension for eibPort 
 12010 KNXnet/IP 
 12020 KNX/TP 

 
EnOcean 

 12030 EnOcean 
 
If the selection is made the configuration window for each technology is opened. As long as the project 
is not saved, this selection is reopened each time the Extension DUO-DMX Gateway is called. 
 
 

5.3.2 KNX CONFIGURATION 

If in the above-described range, the technology "KNX" is chosen, a corresponding configuration window 
is opened, which is specific in its properties to the KNX configuration. In the left half of the window, the 
exported group address file from ETS are loaded (or created manually) and in the right halves the 
address settings are made (Tab LAN/KNX). 
 

 
Figure 35: Extension DUO-DMX Gateway “KNX" 
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1. Enable DHCP 
 

2. IP addresses and setting KNXnet / IP (routing) multicast group 
 

3. List of DUO DMX Gateways in the network. In order to transfer the configuration data via 
"Upload" to a required device it must be marked in this list. It is also determined by marking a 
device -for which the DMX preview is guilty. 
 

4. A click on "Search" displays all available DUO DMX Gateway in the network. The gateway is 
displayed with its corresponding IP address, the name given and current firmware version 
number (since firmware 2.0.0.1). If no name is given for the device the MAC address is 
displayed. If the device you want to program is highlighted in the list and the "Upload" button is 
pressed, all the current configuration data to be transmitted to the device over the network (PC 
and gateway must be in the same network). 
 

5. At this point it is determined which of the two DMX outputs are to activate for the preview. The 
preview is generally enabled only about one of the hooks is set ("Broadcast Preview"). In 
addition, if a device in the list "DMX Gateway" is marked too the preview is only valid for this 
device ("Unicast Preview"). In this case, the PC and the gateway have to be in the same area 
network (subnet). 
 

6. Determines how a scene starts behaving is, when linked to your group address telegram with the 
value "0" is sent. 
 

7. Enter a physical address for the KNX variants of this device 
 

8. The eibPort system ID is preset to a value of "0". This value must be also given to eibPort by the 
creation of the job “coupling facility”. This is only interesting for the "extension" version (Type 
12000) of the gateway. 
 

9. You can give each device a unique name. This name appears in the list "DMX Gateway" instead 
of the MAC address 

 
 

5.3.2.1 LINKING OF KNX GROUP ADDRESSES 

The DMX channels of the two outputs and the created scenes must be linked to group addresses if you 
want to control devices with "Extension", "KNXnet / IP" or "KNX / TP". Do you own an EnOcean device 
the linking is made of EnOcean profiles (see chapter "EnOcean"). 
 
 
SET GROUP ADDRESSES WITHIN THE DMX-CONFIGURATOR  

If no appropriate ESF file with the corresponding group address exists, the group addresses can be 
created directly in the DMX-Configurator.  
 
Proceed as follows: 
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1. Create a Main-, Middle-, and Subgroup: 
Click the right mouse button into the empty group address field while "group addresses" is 
checked. You will be prompted to create a new main group and can assign a name. Then click 
on the main group with the right mouse button and create a new Middle group. The address 
can be created by right-clicking on the middle group. 

 

 
Figure 36: set group addresses 

 
2. Deleting entries: 

To delete an entry, highlight it and press the Delete key on your keyboard. 
 
 
USE ESF DATA 

To link the group addresses from a file called ESF has to be imported. If you have an ESF file from the ETS 
open in the DMX-Configurator menu "Extensions"> "KNX"> "Import ESF" 
 

 
Figure 37: import ESF file 

 
 
After selecting the desired ESF-file, in the left window of the address tree is displayed. The right panel 
contains the configuration tab for the scenes (one for output 1 and 2), for the 512 DMX channels to 
output 1 and 2, and the tab for the "Lan / KNX" - settings. 
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Linking the scenes: 
In the Tab “Out Scene 1 "and" Scene out 2 "all previously scaled scenes are listed. Scenes are started 
by telegrams with the value "1" (data type EIS 1) and either stopped or paused (see "Extension Lan / 
KNX") with the telegram value "0". To create a simple link the desired group address from the tree on 
the left side is drawn to the corresponding scene on the right side. Then the group address is shown 
below the scene. 
 

 
 

Figure 38: linking group addresses to scenes 
 
Each scene can be launched from any number of group addresses. Simply all relevant addresses are 
dragged to the scene. 
 
Linking DMX channels 
In addition to the scenes, the DMX channels can be individually controlled. Since each DMX channel can 
adopt a value from 0-255 here only group addresses as 1-byte value (EIS 14) are used. The linking is 
done the same way as in the scenes. Each channel can be linked with multiple group addresses. 
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5.3.3 ENOCEAN KONFIGURATION 

If "EnOcean" is chosen in the selection of technology, the configuration screen will change slightly. In 
the left half of the window there will be instead of KNX group addresses, from the device received 
EnOcean profiles. The right half adapts well to the EnOcean-specific settings. 
 

 
Figure 39: Extension DUO-DMX Gateway "EnOcean" 

 
It lacks the configuration items for the KNX multicast address and for the KNX phys. Address. The 
explanation of the remaining menu items, see the chapter "Configuring KNX". 
 
 
5.3.3.1 LINKING OF ENOCEAN PROFILES 

In the left half in the "transmitter" will be displayed all from the gateway received EnOcean profiles be 
listed. The profiles will be displayed with their EnOcean specific names. With two clicks (note: Not 
double-click) on the profile name will be a renaming possible. Give the profile a name such as 
"Switch_Wippe1_ON" to assign it better later on. 
 

 
Figure 40: EnOcean Configuration – naming of profiles 
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The DUO DMX Gateway in the EnOcean variant, supporting the profiles” ORG0x5 ". These profiles 
correspond e.g. Touch sensors or window handles. To delete a received profile delete from the list, it 
must be marked and removed with the "Del" key. The profiles are named and light scenes are set, 
simply drag and drop the profiles to the desired channels or scenes. 
 
Linking the scenes 
In case of EnOcean the scenes will be launched and stopped with the same profile. That means one 
rocker switch can start and stop (or pause) two different scenes. The behavior of the scenes in a "stop" 
message is in the tab "Lan/EnOcean" can be determined. 
 

 
Figure 41: EnOcean – Linking of scenes 

 
More than one profile can be linked to a scene. To delete a link, it is enough to mark it and then press 
the "Del" key. 
 
Linking DMX channels 
To link the DMX dimming channels in the DMX outputs directly with EnOcean profiles both profiles of a 
rocker switch must be linked to each channel. 
 

 
Figure 42: EnOcean – linking of DMX channels 

 
The DUO DMX gateway detects a dim-signal when a rocker switch is pressed for longer than 500ms, 
and ended it as soon as the button is released. The dimming up is done by holding the "ON" switch of 
the rocker, the dimming down by holding the "OFF" switch. 
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5.3.3.2 ENOCEAN REPEATER FUNCTIONALITY 

A peculiarity of the Duo DMX Gateway EnOcean variant is that in addition to its gateway functionality it 
also provides a repeater function. The device repeats all EnOcean signals that it receives again and 
therefore amplifies the range of the signal. There are two choices 
 

 
Figure 43: EnOcean Extension - Repeater Functionality 

 
1. Check boxes to activate the repeater EnOcean function. 

 
EnOcean repeaters 
The unit will repeat all received EnOcean radio signals with a lower transmission power. In a system with 
several repeaters thus prevent that a signal is repeated twice. 
 
Level 2 Repeater 
The unit will repeat the signals at full transmission power. Should only be used, if it is ensured that the 
repeated signal does not reach a second repeater. 
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5.3.4 TRANSFER OF CONFIGURATION DATA 

The configuration data can be transmitted over the network or via an SD card. The configuration data 
consists of the stored scenes, the group address and the EnOcean profile - links and the "Lan / KNX" or 
"Lan / EnOcean" settings. The preview settings are excluded. 
 
 
5.3.4.1 TRANSFER VIA NETWORK 

To transfer the data over the network to the device may have to face the PC and DUO DMX Gateway in 
the same area network (subnet). If necessary, change the network settings of your PC before. 
 
Note: Due to the "Upload" will not save the configuration data. If you close the DMX-
Configurator, all changes made are lost. 
 
 
5.3.4.2 TRANSFER VIA SD-CARD 

In addition to storing as DMX project file each project can also be exported as a so called "HEX file" too. 
This file format is required to transmit the configuration data to the DUO DMX gateway. This 
configuration file must always have the same name ("config.par") so that the DUO DMX Gateway reads 
and recognizes them as such. The green "Power" LED sheds light on the state of charge (as long as the 
LED is off , the file is being read). A configuration file is created as follows (after the project is saved as  
*.dx1 file.) 
 

• Open the menu "File"> "Export Hex File" 
• Save the HEX file with a unique name in the appropriate folder 
• Create a folder on your hard drive for the "config.par" file 
• Then copy the generated HEX file into the folder and rename it in to "config.par" 
• Insert the SD card into the card reader and move  the new "config.par" on the SD card 
• Insert the SD card into the slot of the DUO DMX gateway and wait until the green LED lights up 

again. Ready. 
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6 FIRMWARE UPDATE 

To update the firmware of the DUO DMX gateway, please proceed as follows: 
 

• Use a blank SD card and copy the latest firmware file on it. The firmware file must be named 
"dmxknx.fir". 

• Unplug the DMX Duo Gateway from the power supply and insert the SD card into the SD 
card slot. 

• Press the "button" and hold it down while you connect the power supply again. 
• Wait until the LED of the DUO DMX gateway has stopped to flicker and then release the 

button. 
• Remove the SD card and start the machine again by separation of the supply voltage. 
• After a successful reboot is the device works with the latest firmware. 
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7 DEVICE TYPE „EXTENSION“ (EIBPORT 
EXTENSION) 

If the DMX Duo Gateway is used as an extension for eibPort, both devices are “talking” about eibPort 
own BMX protocol. For this is the job of eibPort "linking facilities" is used. In the following the necessary 
steps will be described. 
 
 

7.1 CHECK/SET COMMUNICATION PARAMETERS  

The BMX protocol used for communication either TCP or UDP. In this case, the communication over UDP 
(User Datagram Protocol) is used. Thus the sender (eibPort) and receiver (DUO DMX Gateway) can , 
“talk” together, they must communicate over the same port number. 
 
BMX Port 
Cause in the DUO DMX Gateway the port number cannot be changed it must be set correctly in the 
eibPort. About the "System" - "Configuration" - "Advanced EIB (yabus) Settings" check the port number 
in eibPort. 
 

 
Figure 44: eibPort Communication Parameter 

 
The correct port number is "1735". This number is the default of eibPort, but because this number can 
be changed it should be checked before. 
 
System ID 
In addition, for the facilities coupling a so-called "System ID" is used. That's a number from 0-255 and is 
used -in the case of the facility coupling - to differ coupled KNX facilities from each other in virtual 
plants. For the DUO DMX Gateway the eibPort has to have the system ID "0". The system ID is set under 
"System" - "Advanced EIB (yabus) Settings" - "Configuration". 
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Network settings 
eibPort and DUO DMX Gateway must not be in the same network area for communication. The control 
can (with appropriate firewall - configuration) also take place over the internet. 
 
 

7.2 EIBPORT JOB „LINKING FACILITIES“ 

If the messages should be transferred over the BMX protocol to the Duo DMX Gateway the "linking 
facilities" job is used. This job is also described in the documentation of eibPort. Important 
communication parameters are 
 

 
Figure 45: eibPort Job – Linking Facilities 

 
Host name / IP address 
Enter the IP address of the DMX Duo Gateway. If the communication is done via the internet here a 
DynDNS address entered. 
 
connection Type 
It is used for the direct connection via LAN ("direct (LAN)") 
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Target system ID 
Determines to which system ID the packet should be sent. Because the DMX Duo Gateway ID "0" is set 
by default, must be "0" set here. 
 
Regulate 
You can decide with the help of rules which addresses are transmitted. All addresses, only a single 
address or only selected areas are used. 

Rule Meaning 

*/*    ->   */* All main and sub groups of the EIB-Installation 1 will be coupled 1:1 to EIB-
Installation 2. 

6/*   ->   6/* All group addresses from main group 6 of EIB-installation 1 will be coupled 1:1 
with main group 6 of the EIB-installation 2  

7/*   ->  17/* All group addresses of main group 7 of the EIB-installation 1 will be coupled 
with the virtual main group 17 of the EIB-installation 2  

 In this case no eib address overlapping is possible within installation 2 

*/1  ->   */1 Addresses 0/1; 1/1; 2/1...32/1 are coupled directly with EIB -installation 2  

 
Using these rules it is possible to map group addresses. In case of the DUO DMX gateway this makes no 
sense. On the side of the DUO DMX gateways only the addresses which have been linked via the ESF file 
are working. 
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8 GENERATE ESF DATA 

For linking ESF data with the DMX Configurator you have several options. 
 
ESF data from the eibPort device 
Since firmware version 1.0.2 (Version 3) eibPort opens up the possibility to export its group address to 
ESF data file. Go to the menu in the "Editor" - "Tools" - "ESF Upload & data maintenance." Insert the 
wanted addresses in eibPort and export it as an ESF file. 
 
ESF data from the ETS 
To generate the desired data with ETS, you need the application of a device which controls the data 
types 1bit or 1byte. Linking the addresses you want and export the data as ESF. 
 
ESF file created individually 
Look for an existing ESF file, that contains 1it and 1 byte communication object and open it with a text 
editor. Using the same syntax, you can modify the file so that you comply with your requested addresses 
and data types. 
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